WPJAM Basic 为什么要求 PHP 7.2 以上版本

不铺垫了,直接来:

PHP 7.2 速度快

PHP 升级到 7 之后,效率直接提高了 2-3 倍,特别是开启 OPCCache 的 PHP 7,经过测试,比 PHP 5.6 都快近10倍,这是数量级的差别。

这一点升级到 7 之后版本的 WordPress 的博主感受是最深刻的,以前感觉 WordPress 有些慢,但是到了 7 之后,安装了 OPCCache + Memcached 之后,基本都能秒开了,只要你搭配 WPJAM Basic 插件就好。

另外搜索引擎对网站速度的要求是第一位的,如果你的网站不能第一时间打开,搜索引擎自然而然就给你降权的。

PHP 7 是跨时代的版本,但是 PHP 7 在 2019 年之后就将不再维护了,PHP 7.1 和 7.2 分别升级了一些特性之后,性能也进行一定的提升,所以建议一步到位 PHP 7.2 吧。

PHP 5.6 在2018年底就不再维护

PHP 官方宣布在2018年12月31日起 PHP 5.6.x 的安全支持将正式停止,那么到时候,如果你的网站如何还跑在 PHP 5.6 上面的话,将不再安全。所以尽快更新

WordPress 官方推荐 PHP 7.4

WordPress 在2016年2月份起,也在官方安装要求里面,建议使用 PHP 7.0 以上的版本,现在已经要求 PHP 7.4 了:

PHP 7.2 新特性很好用

举几个自己最常用的新语法特性:

??语法

日常使用中存在大量同时使用三元表达式和 isset() 的情况,PHP 7添加了null合并运算符 (??) 这个语法糖,如果变量存在且值不为NULL, 它就会返回自身的值,否则返回它的第二个操作数。

比如原来的 PHP 5 的代码:

$username = isset($_GET['user']) ? $_GET['user'] : 'nobody';

就可以简写为:

username = $_GET['user'] ?? 'nobody';

太空船操作符

太空船操作符用于比较两个表达式,比如下面当$a小于、等于或大于$b时它分别返回-1、0或1。

echo $a <=> $b;

如果 PHP 5 的话,你需要这样写:

echo $a > $b ? 1 : ( $a==$b ? 0 : -1 );

短数组语法

现在 list() 支持在它内部去指定键名,这意味着它可以将任意类型的数组 都赋值给一些变量。

$data = [
    ['id' => 1, 'name' => 'Tom'],
    ['id' => 2, 'name' => 'Fred'],
];

while (list('id' => $id, 'name' => $name) = $data) {
    // logic here with $id and $name
}

而在 PHP 7.1.0 之前的版本,list() 仅能用于数字索引的数组,并假定数字索引从 0 开始。

另外 PHP 7.3 新增三个非常方便常用的函数,is_countablearray_key_firstarray_key_lastWPJAM Basic做了兼容,这三个常用函数,在 WordPress 中可以立即使用

WPJAM Basic 要求 PHP 7.2

所以建议使用 PHP 7.2 或者以上的版本,WPJAM Basic 新版也只针对 PHP 7.2 做维护更新了。

很多同学和我说他的主机最高只支持 PHP 7.1,换一个吧,直接使用阿里云的服务器吧,直接安装一个宝塔,剩下的都会非常容易,配合 WPJAM Basic 插件的要求,安装 OPCCache 和 Memcached,你的博客也会飞起来。

如果你这些都不会,只想安静的做的网站和内容,那么你也可以找我们,我们提供 WordPress 优化服务,当然也可以帮你进行服务器安装和管理。


©我爱水煮鱼,本站推荐使用的主机:阿里云,国外主机建议使用BlueHost

本站长期承接 WordPress 优化建站业务,请联系微信:「chenduopapa」。